明月登楼

军哥LNMP 1.4一键安装包升级到PHP 7.2.0失败的解决办法
  使用军哥LNMP 1.4 一键安装包的站长们近期可能会发现,在LNMP里更新PHP到最新正式版 7.2.0的时...
扫描右侧二维码阅读全文
10
2017/12

军哥LNMP 1.4一键安装包升级到PHP 7.2.0失败的解决办法

  使用军哥LNMP 1.4 一键安装包的站长们近期可能会发现,在LNMP里更新PHP到最新正式版 7.2.0的时候会出现更新失败的问题,吓得明月都放弃更新PHP 7.2.0的计划了,还好今天明月在坛子里看到了解决办法,不少站长反馈已经成功更新编译成功了,就分享给大家!

  先看看更新编译失败的截图:

Capture.PNG

  其实解决办法很简单,只需要修改lnmp1.4目录下的 include/upgrade_php.sh文件里最后倒数几行中的 7.[01] 改为 7.[012]即可。

  具体操作如下:

cd lnmp1.4
vim  ./include/upgrade_php.sh

  修改下图所示位置的代码即可:

20171210220648.png

  保存退出,然后运行lnmp1.4的模块升级脚本更新PHP到7.2.0即可:

./upgrade.sh

  如下图,顺利的进入编译阶段即表明成功更新中……。

php720.png

明月发现在使用LNMP过程中有任何的问题的时候,到坛子里看看一般都有不小的收获,呵呵!

最后修改:2017 年 12 月 10 日 10 : 22 PM
如果觉得我的文章对你有用,请随意赞赏

发表评论

13 条评论

  1. 巴中热线

    谢谢分享,正要升级discuz和php7

    1. 明月登楼
      @巴中热线

      客气了,欢迎常来哦!

  2. 狂放

    抱紧我的宝塔

    1. 明月登楼
      @狂放

      呵呵,宝塔虽好,还是限制太多了!

  3. 清雨

    打开这个站点的速度比以前慢了一倍以上

    1. 明月登楼
      @清雨

      找到慢的原因了,竟然是插件造成的!

      1. 清雨
        @明月登楼

        不必要的插件还是不装好

        1. 明月登楼
          @清雨

          是呀,当时收欠装了个Access插件,就是网站统计的插件!就是它造成网站越用越慢的!

    2. 明月登楼
      @清雨

      是的,我也有这个感觉,不知道问题出在哪里了!ớ ₃ờ

  4. 刘晨晨

    恰到好处,正准备抽个时间更新呢

    1. 明月登楼
      @刘晨晨

      呵呵,多谢支持哦!

  5. 孤人情酒

    还没有专门更新过LNMP里的PHP呢!哪天试试去!

    1. 明月登楼
      @孤人情酒

      呵呵,我最近也没有折腾了!