明月登楼

LNMP 1.5环境下多PHP版本共存部署
今天明月帮朋友运维的服务器下有一个网站安装织梦CMS,因为织梦CMS对PHP 7.2的支持不够完善和稳定,所以就需...
扫描右侧二维码阅读全文
12
2018/06

LNMP 1.5环境下多PHP版本共存部署

今天明月帮朋友运维的服务器下有一个网站安装织梦CMS,因为织梦CMS对PHP 7.2的支持不够完善和稳定,所以就需要一个多PHP版本的环境来区别支持各个站点,在军哥LNMP1.5一键安装包下的LNMP环境明月还是第一次尝试部署PHP多版本共存,所以今天就当做学习笔记记录分享一下。

image000.png

目前多PHP版本只支持LNMP模式,LNMPA、LAMP模式下不支持!

要使用多PHP先安装多PHP版本,在lnmp1.5源码目录下运行:./install.sh mphp 按提示选择要另外安装的PHP版本,不能多选,只能选一个,要安装多个需要安装完成后再运行前面的安装命令。

已经升级完LNMP管理脚本且已安装好多PHP版本的话,lnmp vhost add 时会在设置完日志名称后提示当前已经存在的PHP版本,按提示的数字选择就可以。

如果已经存在的虚拟主机要更改PHP为指定版本需要修改虚拟主机的配置文件,配置文件为 /usr/local/nginx/conf/vhost/域名.conf ,将里面的include enable-php.conf; 替换为 include enable-php7.1.conf; 前面的7.1为php版本,可以根据自己的需要进行修改,但必须要对应的多php版本已经安装,要不然会提示502错误(只要已经多PHP版本安装完成了,对应就会产生对应版本的这个eable-php.conf文件的)。

修改后必须要重启nginx,否则无法生效。

如要使用新版里面的PHP模块组件安装工具需要升级一下PHP才能使用新版PHP组件安装工具。

多PHP模块安装依然和以前一样只不过存在多PHP版本时会让你选择为哪个版本的PHP安装PHP模块/组件

最后修改:2018 年 06 月 12 日 07 : 52 PM
如果觉得我的文章对你有用,请随意赞赏

发表评论