明月登楼

Nginx 1.14.2 稳定版发布,建议大家更新!
最近Nginx爆出了漏洞(如: HTTP/2 (CVE-2018-16843,CVE-2018-16844)以及 ...
扫描右侧二维码阅读全文
06
2018/12

Nginx 1.14.2 稳定版发布,建议大家更新!

最近Nginx爆出了漏洞(如: HTTP/2 (CVE-2018-16843,CVE-2018-16844)以及 MP4 模块(CVE-2018-16845)中的漏洞)等,在Nginx 1.14.1 稳定版和 Nginx 1.15.6 主线版中已经修复了这些漏洞,今天Nginx 1.14.2 稳定版也发布了,主线版也更新到了Nginx 1.15.7,如果你的Nginx低于1.14.1,明月建议你尽快升级。

logo.png

Nginx 1.14.2 稳定版已发布,更新如下:

  • stream 模块中新增 “proxy_requests” 指令
  • “limit_req” 指令新增 “delay” 参数
  • 修复重构期间的内存泄漏
  • 修复 $ upstream_response_time、$ upstream_connect_time 和 $upstream_header_time 变量相关的问题
  • 修复当在 32 位平台上使用 ngx_http_mp4_module 时,工作进程中可能发生分段错误的问题

更多细节可查阅:

https://nginx.org/en/CHANGES

下载地址:

https://nginx.org/en/download.html

最后修改:2018 年 12 月 21 日 02 : 18 PM
如果觉得我的文章对你有用,请随意赞赏

6 条评论

  1. 阿南

    1.15以上

    1. 明月登楼
      @阿南

      我也是最新的1.15

  2. 黑桃三

    多谢提醒,已更。

    1. 明月登楼
      @黑桃三

      客气了,多谢支持,欢迎常来哦!

      1. 黑桃三
        @明月登楼

        我也准备买你这个主题,搞个自留地。刚才联系作者不在线。。。

        1. 明月登楼
          @黑桃三

          哦,太晚了估计!

发表评论